[WBEL-users] problem with rsync script

Lamar Owen lowen@pari.edu
Tue, 16 Nov 2004 16:55:37 -0500 (EST)

> Yes, yes, I know, there's other distros out there.  I'm gonna look at them
> tonight.

I just yum upgraded a server from WhiteBox 3respin1 to CentOS, just to see
how difficult it would be.  Here's my history:

#yum -C clean all
#rpm -Uvh
#cd /etc
#mv yum.conf yum.conf.rpmsave.WB3
#cp yum.conf.rpmnew yum.conf
#rpm -e whitebox-release
#rpm -Uvh
#rpm --import
#rpm --import
#yum upgrade

Reboot, and now I'm running the CentOS kernel and pointed at the CentOS
yum repos. Everything seems to work ok.  It downloaded a number of
updates; 93 in fact for my box, including the kernel.  Took about fifteen
minutes on my pipe with that box (Dell PowerEdge 1750).

One could probably do the same thing in reverse, or to Tao, or SL, or others.

If I run into problems, I'll let everybody know.  Otherwise, in a few days
I'm doing the rest of my servers.

Note that the closeness of both CentOS and WhiteBox to RHEL3 is the reason
that this worked at all, much less as smoothly as it appears.  This sort
of forced upgrade is not really recommended for migration between systems
of dramatically different types, such as an RHEL3 to RHEL4-beta upgrade. 
Or FC2 to Fc3 for that matter.  YMMV.
Lamar Owen
Director of Information Technology
Pisgah Astronomical Research Institute
1 PARI Drive
Rosman, NC  28772