[WBEL-users] Stop the Hardware Check

bishop bishop@platypus.bc.ca
Fri, 24 Sep 2004 11:25:15 -0700

John Hinton wrote:
> bishop wrote:
>> John,
>> In the lab, we usually turn ogg the USB on the 1600/1850 line, and 
>> that helps with a lot of OS installs.  Something in the CPQ USB stuff 
>> fools the HW detection.  The NCR/LSI SCSI shoudl go in fine;  never 
>> had a problem with it, not in every RH since 6.0.
>> Lemme know if you can turn off the uSB, and if it affects it at all.
>>  - bish
>> John Hinton wrote:
> First, I only started hitting this issue with RH 7.3 I think?... for 
> sure not 7.2 and it might have been rh8 or rh9 where it started? To get 
> around it once, I did the install on a 3000R and moved the drives to the 
> 1850 and that worked!! :) mother of invention.......
> In SmartStart (5.1), there are no references to USB as this machine has 
> no USB (maybe a later SmartStart would have the option?). I have updated 
> to the latest BIOS on this machine. Previously, on other 1850s, I had 
> always done the install with linux nousb, and the install worked. This 
> is however a dual 600 1850 with Ultra 2 scsi, which makes it one of the 
> last made and I kept hitting snags.
> I also did linux nousb nousbstorage and again the install went fine... 
> but the system first would hang on kudzu during first boot... turned off 
> kudzu via single mode and it hung just after detecting the mouse on 
> startup. I also noticed that during startup, there was a lot of USB 
> stuff being loaded... one area showed failure and it went by fast on the 
> screen, but in the many reboots it seemed to refer to USB storage.
> On first bootup, it also loaded USB keyboard and mouse, even though I 
> had done the linux nousb install. So, it seems that this switch only 
> works through the installation OS loadup, but does not actually affect 
> what gets installed or configured.
> So, since I had no SCSI devices on the two onboard SCSI ports, I figured 
> what the heck and turned them off.... Everything worked fine from there. 
> I wish I had tried an install without the nousb, but I bet it would have 
> worked after turning these off. Also, 'IF' there were devices on these 
> ports, I bet it would have correctly identified them as drives and not 
> had snags. I do have another one of these units to set up, except it is 
> a bit older as it is a dual 550, but will try some things with it.
> Anyway... seems I was the first to discover the nousb thing some time 
> back on bugzilla.. and reported the cure to after redhat could come up 
> with nothing... and have been just happily doing the installs... and 
> then... boom!! This 'newest' to me box suddenly had all sorts of problems.
> Hope this was a good answer to your question. Perhaps you have some 
> input about later versions of SmartStart?

I'm not gonna be much more help, I'm afraid.  The facts of the matter 
are that I'm not a lab guy but merely repeating what they've said on 
occasion about installing linux or unix on them. My own installs on a 
1600 and 1850 went well, but that was the RH62 and NSC kind of 
time-frame, and only as required by my ISV work.  I can only assume they 
*must* be referring to the Bios as I'm all but certain these boxes 
indeed don't have the USB connection as well.

I can't confirm anything like that personally, any longer.  I've since 
moved to telecommuter status, because it's freer for me and cheaper for 
the company.  Since the power in apartments isn't even close to what's 
in the lab and what CPQs like, I've slowly replaced ageing ProLiants 
with white boxes (neqx.com, ncix.com) asI moved across and out of the 
country.  Since dropping off the last one at a co-worker's garage about 
a year ago - the difficulty in moving out of the US is proportional to 
the square of the number of computers in one's possession at the time - 
I've not even looked at the heavy, noisy little buggers or, thankfully, 
had to pack them anywhere else.

Nice machines, otherwise.  Sorry I can't be more help.

  - bish