[WBEL-users] RAID problem

Simone simone72 at email.it
Fri Apr 15 11:45:21 CDT 2005

Simone wrote:
Just for you to know, it didn't work. dd if=/dev/hda2 of=/dev/hdc2, then 
tried to raidstart /dev/md2, it won't start.


> Hi list, I am having the following problem on one of the servers. Due 
> to a IDE controller malfunctioning on the mobo, my partition /dev/hdc2 
> part of a software raid 1, disappeared. Went down in the server room, 
> rebooted, readded the hdc2 to the array, started rebuild process, but 
> when it was almost done the /dev/hda2 partition disappeared from the 
> system. So now I probably have usable data on the hda2 partition, but 
> this is set as the faulty one of the raid, so I cannot run a 
> raidhotadd otherwise the useless data on hdc2 will overwrite the 
> hopefully good ones on hda2. This is the situation if I start the raid:
> md2 : active raid1 hdc2[1]
>      4915776 blocks [2/1] [_U]
> Tried to raidhotremove hdc but it won't let me, tried to raidsetfaulty 
> hdc, no success. The only thing I can think of right now is to stop 
> md2, then dd all the datas from hda to hdc restart md2 and see if it 
> works. I thought perhaps there's a way to tell raid to start md2 using 
> just hda2.
> I will be looking for an answer on the net, meanwhile if you have any 
> suggestion to get the server up and running I would be very grateful.
> Thanks, Simone
> _______________________________________________
> Whitebox-users mailing list
> Whitebox-users at beau.org
> http://beau.org/mailman/listinfo/whitebox-users

More information about the Whitebox-users mailing list